Search This Blog

Loading...

Wednesday, July 28, 2010

Tool update: View Layout Replicator

Here is an update again… Well, that should be the last one as the tool should manage every aspect of a view layout from now.

So, the problem was the following: When views were replicated, some attributes that are not used in the layout were remaining in the fetchXml part of the view (the part that defines which records will be displayed).

This avoids to delete these attributes from the entity as they were still used in a published view, even if you were not able to remove this reference (Unless you export the customization, remove the attribute from the fetchXml and import back the updated customization).

This new version takes care of the layoutXml (which columns are displayed) AND the fetchXml (which attributes are retrieved under which conditions).

I hope nobody was affected by this problem.

As usual, you can download the latest version on the right pane of this blog.

9 comments:

David said...

Hi,

Great and invaluable tool! I have found a bug, though. When I try to copy view from or to any associated view, program crashes.

I hope it's a simple fix and you publish a new version soon!

Regards, David

Tanguy said...

Thank you David, I have corrected the bug (it seems that the associated view doesn't have any fetchXml value...)

You can download the new version.

Hope that no other bugs will be found ... :)

Brad said...

Tanguy,

I used your view to replicate 5 or 6 views in the Opportunity form. I used downloaded the tool from the right hand navigation in this blog.

I beleive I see an issue.

I have two entities, Opportunty and Request. The Request entity is stand alone but a user can select a parent Opportunity using a lookup field back to the Opportunity form. The first two fields of the lookup form are a Lookup field to "Sales Stage" a serperate entity and the second field is the name of the Opportunity.

Here is what I see. When a user within the Request Opportunity attempts to use the Opportunity lookup to select one if thefirst field Sales Stage populated it populates the lookup with the Sales Stage, not the Opportunity name. This only happens when the sales stage is populated, if it isn't populated it shows a blank lookup title until the record is saved where is shows the opporunity name.

Great tool, I am very happy for the development your doing, I just wanted to share with youo what I see. If you have any questions let me know. Provided your link on the right side of this blog is correct I beleive I have downloaded your latest version.

Are you versioning your tools btw?

Brad said...

Fix. I beleive there may be an issue when your attempting to replicate a view to the system "Lookup View".

I reverted back to an old customization, the lookup view was reset back to its orgiginal state, the views I created with your tool remained.

Hopefully there are no permananat issues, once again let me know if you need help recreating this.

Tanguy said...

Hi Brad,

Thank you for the feedback.

Could you send me the customization file for the entities involved in the issue?

My email : tanguy 92 [at) hot mail (dot) com (remove space and use special character @ and . instead of their description)

Brad said...

I have not forgot about sending you this, I'll explain the delay when I email you. In addition there seems to be an issue with the default view. One of the views I used to update with the tool does not allow me to change the default view now. It actually shows two default views in the customizations, but the original one is the actual default.

Tanguy said...

That is strange since the tool is clearly not dealing with the "IsDefault" property.

Moreover, I looked into the dll that performs the change of the default view and it only changes the property "IsDefault", so even if something was "broken" in the view because of the tool, it shouldn't behave like you describe... as I said, really stange...

Jeff said...

Hi Tanguy,
I have a problem with the View Layout Replicator. I have an entity called Product Offering (PO) (basically a 1:N child entity of Opportunity) and a 1:N child entity called Product Offering Item. (POI) In the default view for the POI entity I have a column from the PO entity. When I click on the default view for POI the replicator crashes. If I remove the column it works fine. Any ideas?

Thanks.

Tanguy said...

Hi Jeff,

Could you send me your customization (only entities impacted)?

My address tanguy92{arobase}hotmail(.)com